User Tools


Installing wallabag

requirements

  • PHP 5.3.3 or higher
  • XML (?)
  • PCRE (?)
  • Data filtering (?)
  • Tidy (?)
  • cURL (?)
  • Parallel URL fetching
  • allow_url_fopen (?)
  • SQLite for PHP
  • gettext (?)

You can execute wallabag_compatibility_test.php (in your wallabag folder) to check if your server is good.

downloading

Click here to download the latest version.

Then, extract it on your server.

installing

dependencies

wallabag uses Twig as template engine. You have to install it with Composer.

curl -s http://getcomposer.org/installer | php
php composer.phar install

If you cannot install Twig with Composer, you have to download this file: http://wllbg.org/vendor and extract it in your wallabag folder.

upgrading

To upgrade your wallabag installation to the newest version, you must download the latest version to your server, extract it, and copy it into your installation path. Then empty the cache directory and remove the install folder.

The commands are as follows:

 wget http://wllbg.org/latest -O wallabag-latest.zip
 unzip wallabag-latest.zip
 rsync -ur wallabag-VERSION/* YOUR_WALLABAG_INSTALL_DIR/
 cd YOUR_WALLABAG_INSTALL_DIR/
 rm -r cache/* install/

Please adjust VERSION and YOUR_WALLABAG_INSTALL_DIR accordingly.

Go to your Wallabag. Enjoy!


wallabag documentation

documentation for the self hostable application to save web pages

Site Tools